
1. Overview 

AgroEye is an advanced Open Source application for Polish Agency for Restructuring and 

Modernisation of Agriculture (Eng. ARMA, pl. ARiMR). AgroEye is designed to support 

verifying agricultural lands in terms of European Union Good Agricultural and Environmental 

Conditions (GAEC). Application provides fast, accurate and simple way to check the dynamic 

of agricultural changes in order to help ARMA control rules related with direct payments. 

Many of GAEC rules require field evaluation couple of times within a year, together with 

spatiotemporal analysis. With remote sensing approach, it is possible with reasonable 

financial expenditures.  

More generally, this system is designed to easy use spatial analysis system for agriculture 

which can be used not only by ARMA. AgroEye application will also be offered to other 

agencies (like National Parks, Polish State Forest National Holding, General and Regional 

Directorate for Environmental Protection). Prepared user friendly application that gives what 

is need for decision making will popularise both satellite imagery and will the trust in quality 

of spatial analysis. 

 
Figure 1. Main Window of AgroEye (Image – Sentinel-2 11.01.2016 ESA). 

 

1.1. About the software  

The AgroEye is developed with Python programming language, with only use  the Open Source 

modules and libraries. The application is not limited to only one operating system, it runs both 



on Windows and  on different GNU/Linux flavours. The AgroEye is redistributed in number of 

ways. Firstly, the source code is available to download from Bitbucket. The end-user can 

download python scripts, compile the C++ modules and run with Python Interpreter. The other 

way of distributing application is the prepared package containing all necessary modules (and 

precompiled if necessary) plus preconfigured Python Interpreter. The second manner is aimed 

to regular Windows users. 

2. Basic Concepts 

This chapter introduces elementary terms of analysis with AgroEye. 

2.1. Raster and Raster Bands 

Raster is a set of raster image data. Each raster band represents a type of information. The 

most common raster bands are Red, Green and Blue (RGB) bands. The Sentinel-2 contains 13 

spectral bands: four bands at 10 metres, six bands at 20 metres and three bands at 60 metres 

spatial resolution. 

Table 1 Sentinel 2 bands with resolution and wavelength. 

Sentinel-2 Bands Central Wavelength (nm) Resolution (m) 

Band 1 – Coastal aerosol 443 60 

Band 2 - Blue 490 10 

Band 3 – Green 560 10 

Band 4 – Red 665 10 

Band 5 – Vegetation Red Edge 705 20 

Band 6 – Vegetation Red Edge 740 20 

Band 7 – Vegetation Red Edge 783 20 

Band 8 - NIR 842 10 

Band 8A – Vegetation Red Edge 865 20 

Band 9 – Water vapour 940 60 

Band 10 – SWIR - Cirrus 1375 60 

Band 11 - SWIR 1610 20 

Band 12 - SWIR 2190 20 



 
Figure 2. Figure 2 Spectral and spatial resolution of Sentinel-2 imagery (source: 

http://www.mdpi.com/2072-4292/8/3/166/htm) 

Sentinel-2 images are stored in format JPEG2000 with *.jp2 files extension. AgroEye can open 

raster file stored as .tiff, .jp2 or other raster file format with supporting georeferencing.  

Inside AgroEye images are represented by layers.  

2.2. View Area 

AgroEye loads raster and vector data into View Area. View Area consists of one or more layers 

or bands of one image file. View Area include additional information related to the file, such 

as coordinate system. Each View Area representing one set of data used in AgroEye software 

is managed in project. 

2.3. Layer 

AgroEye loads image data as layers, which means that each layer represents one raster or 

vector file. The layer consists of one or more image bands. Layer can include additional 

information related to the file, such as metadata or geoinformation.  

2.4. Project 

Project file stores references to the opened layers and related information about coordinate 

system and View Area settings. During creation of a project, layers are referenced into project. 

The results of GAEC is not added to project. Layers from classification are saved into temporary 

directory. The project file is saved as an .xml project file. 

2.5. Table of Contents 

http://www.mdpi.com/2072-4292/8/3/166/htm


Table of Contents is a container for layers. It contains raster and vector data references. In 

the Table of Contents,  you manage the loaded files. Here you manage all data of your 

project. 

 

Figure 3. Table of Contents with loaded files as drop-down menu. 

 

2.6. Segment Objects 

The image layer is transformed into segment objects during the process of segmentation 

which is one step of GAEC rules. Segment objects are stored in SpatiaLite database. Every 

single segment object can provide information about this geometry and precalculated 

statistics (mean value or standard deviation). Storing the segment objects in database 

simplifies and speeds up the process of classification.  

 



Figure 4. Outlines of segments processed by Agroeye. 

2.7.  Vector 

AgroEye software enables the possibility to work with vector data. Vector is consisted of 

points, that may be grouped into objects representing lines and polygons. Vector objects at 

top level are called features. AgroEye loads vector data as layers. 

There are four major vector data formats supported by AgroEye: 

 ESRI Shapefile 

 KML (Keyhole Markup Language) 

 GPX (GPS eXchange Format) 

 SpatiaLite DB 

 

2.7.1. ESRI Shapefile   

Shapefiles store geometry and attribute information about features. The geometry of feature 

is stored as a shape comprising a set of vector coordinates. Shapefile is nontopological what 

makes faster drawing and edit ability. It requires less disk space than raster data and is easier 

to read and write. In AgroEye reading Shapefile is necessary in order to ARiMR database which 

contains a polygon set with attributes on special fields. In the environment with juridical 

consequences, the explicit dataset needs to be delivered under supervision of the responsible 

control agency and we cannot use our own interpretation of the GIS layers. 

2.7.2. KML 

KML files are used to display data in an Earth browser such as Google Earth, they store vector 

coordinates and more detailed information. The results of classification contains fields with 

anomalies that may be extracted as a KML file. That function enables the usage locations 

directly, in mobile phone, tablet without any special devices or conversion in other GIS 

application. 



 

Figure 5. KML file with anomalies opens in Google Earth. 

2.6.3. GPX 

It is data format for interchange of GPS data (waypoints, routes and tracks) between software 

and GPS devices. It stores coordinate data. Results of classification contains fields with 

anomalies may be extracted as GPX file. It is useful in the case of use GPS device, which are 

used in control agency. 

 

2.6.4. SpatiaLite Database 

SpatiaLite is extension of regular SQLite database system. It contains not only the geometry 
data with attributes (like ESRI Shapefiles) but also index them spatially and adds spatial 
functionalities. That enables to execute queries based on spatial attributes and relationship 
rather than query values in SQLite approach. 

 

2.7. Class and Classification 

Classification is a procedure that associates segment objects with an appropriate class labeled 

by colour. Information contained in segment object is used as a filter for classification. Based 

on this, segment objects can be analysed according defined criteria and assigned to 

appropriate classes. The classes are provided by AgroEye and depend on the GAEC rules.  

2.8. GAEC rules 

GAEC rules represents a predefined workflow with blocks. Configured workflow can perform 

different tasks like segmentation, classification, statistics or export of results to file. Workflow 

is sequenced and represents ready to use solution to GAEC rules. Standard workflow consists 

of set of processes with defined parameters. Workflow can be designed only by AgroEye 

Developers.  



 

Figure 6. Example of workflow with blocks for GAEC no.1. 

2.9. Algorithm 

The algorithm defines the operation the process will perform. This can be generating new 

layer, segmenting, merging raster data with vector data, classifying fields, and so on. The two 

main functions are segmenting and classifying segment objects. Other algorithms help to 

define all necessary operations to set up GAEC rules. The following functional categories of 

algorithm exist: 

 Segmentation algorithms 

 Classification algorithms 

 Export algorithms 

 Raster layer operation algorithms 

 Vector layer operation algorithms 

2.10. Segment size 

The segment size describes the objects size which are generated in Chessboard Segmentation. 

Value of 1 will generate objects of 1x1 pixel. The size is predefined by the user.  

 

Figure 7. Outline of segment objects with different object size (left: 50, right:120). 

2.11. Threshold  

Threshold value describes the upper boundary of objects size which are generated in Quadtree 

Segmentation. The threshold is defined by the user.  

 



3. Workflow 

This chapter presents an overview of the workflow and sequences the basic operational steps. 

3.1. Load and Manage Data 

Raster and vector data can be analysed in a single project which can contains several files. All 

files are stored in Table of Contents. In the Table of Contents, you manage your files. To run 

an automated GAEC rules you first have to import data to AgroEye.  

3.1.1. Work with Project 

A single project is used to analyse image data.  

3.1.1.1. Open project 

You can open project and investigate it in the View Area. You need an .xml file containing 

project. To view project that is not a part of AgroEye, you must open it from .xml file.  

 Choose File → Open Project on the main menu bar. The Open Project dialog box opens. 

  Select a project stored as the .xml file. 

 Click open and the project will display in the View Area. 

If an existing project or its data have been moved, the references to the file data may have 

got lost. If you try to open second project in AgroEye instance, the other one closes 

automatically. To open and view more than one project simultaneously, you have to start 

multiple AgroEye instances. 

3.1.1.2. Save project 

You can save a project. The output can be created as an .xml file. The project contains 

information about current View Area – spatial reference system, range of view, pixel size, 

loaded files and other relevant settings.  

 

Figure 8. Left: Save project window; Right: Example of .xml project file. 

3.1.2. Work with file 



3.1.2.1. Supported Raster Formats 

Table 2 Supported Raster Formats. 

Import File Format (Driver) File 

extension 

JPEG 2000 .jp2 

Tagged Image File (GeoTIFF) .tif 

KEA Image Format .kea 

IMG .img 

 

3.1.2.2. Supported Vector Formats 

Table 3 Supported Vector Formats. 

Import File Format (Driver) File extension 

ESRI Shapefile .shp 

Keyhole Markup Language .kml, .kmz 

GML .gml 

GPS eXchange Format .gpx 

Geography Markup Language .gml 

SpatiaLite database .spatialite 

 

3.1.2.3. Georeferencing  

Georeferencing is automatically detected by AgroEye or can be set up manually. Files with no  

spatial projection are not loadable. AgroEye has the ability to reproject layers on-the-fly, 

therefore all layers can be displayed in one coordinate system. If the coordinate system is 

supported, geographic coordinates from inserted files are detected automatically.  

View Area has the global coordinate system. If new files are added, they are automatically 

displayed using the same coordinate system as the View Area. The View Area coordinate 



system does not need to be the same as the data that the you are applying, because it will 

project the data on the fly. When AgroEye is started with a new, empty View Area, the default 

coordinate system is not defined. The first file added to an empty map sets the coordinate 

system. 

3.1.2.3.1. Change coordinate system 

You can change coordinate system at any time but you need to be aware that projecting on 

the fly can take longer to draw. Drop down menu in View Area contains the list of the most 

frequently used in Poland coordinate systems. You can add other coordinate system using 

EPSG Code. 

 

Figure 9. Drop-down menu with coordinate system. 

 

3.1.2.3.2. View Area coordinate system 

The current coordinate system for View Area is shown at the bottom of the AgroEye in drop 

down menu.  

 

Figure 10. Coordinate system in View Area. 



3.1.2.3.3. File coordinate system 

In order to see the predefined coordinate system to the file, you can click in the Table of 

Contents and click Properties. You can read information about EPSG Code, Projection name 

and Projection definition. 

 

Figure 11. Properties with information about coordinate system. 

3.1.2.3.4. Remove file 

To remove a file, select file in the Table of Contents and click Remove layer. 

 

Figure 12. Table of Contents with remove Layer. 

3.1.2.3.5. File naming 

File in Table of Contents has names that include the path to the file or only the same name. 

To set the showing style select file in the Table of Contents and click Showing Style. Next you 

can choose two variants.  



 

Figure 13.  Table of Contents with Showing Style. 

 

3.2. View Data in Project 

You have several options for viewing data. Some of the visualization tools are dependent on 

the file format.  

3.2.1. Change Display of Image Layers 

You can define the colour composition for the display of image bands. Go to the Table of 

Contents and select raster file and click right mouse button. In the displayed context menu 

click on Raster RGB Composition. Raster RGB Composition set display options.  

 

Figure 14. Composition RGB window. 

 

3.2.1.1. Greyscale Composition 

Raster are automatically assigned RGB (Red+Green+Blue) colours by default when an raster with 

three or more bands is loaded. Use the Greyscale Composition button in RGB Composition to display 



the image bands separately in greyscale. Next choose the band which will be displayed in greyscale 

using Greyscale Channel. 

 

Figure 15. Greyscale project view of sample image. 

3.2.1.2. Three Layers RGB 

Display three bands to see raster in RGB (Red+Green+Blue) mode. By default, layer 3 is 

assigned to the Red channel, layer 2 to Green, and layer 1 to Blue. These are additively 

mixed do display the raster in View Area.  

 

3.2.1.3. Edit Raster Layer Composition 

You can define the colour composition for the visualization of raster bands for display in 

View Area. You can choose from different options. To change the composition of layers, 

open the Raster RGB Composition dialog box and change Channel Red, Channel Green, 

Channel Blue. Save result by clicking Apply. One layer can be displayed in more than one 

colour. 

 

Figure 16. Set Channel Red, Channel Green, Channel Blue. 

 



3.2.1.4. Edit Colour Palette 

You can define the colour palette for the visualization of raster bands for display in View 

Area. 

 

Figure 17. Project view of sample image using colour palette. 

3.2.1.5. Edit opacity  

You can define value of opacity of raster bands for display in View Area. To change opacity, 

open the Raster RGB Composition dialog box. Use the opacity slider to adjust the opacity of 

the Raster or enter value. Opacity is helpful in visualizing the transitions between layers.  

 

Figure 18. The opacity slider. 

3.2.1.6. Layers Histogram 

The raster bands provides information about the distribution of values on single image 

bands To open histogram go to the Table of Contents and select raster file and click right 

mouse button. In the displayed context menu click on Show Histogram and Adjust.  



 

Figure 19. Histogram window. 

3.2.1.7. Layers stretch 

Users can apply a stretch when raster display appears dark. User can check if stretch all 

raster or only current extent. In the second way, the statistics of layers are computed for 

current extent, too. 

There are different modes for image stretching: 

None 

No stretching allows you to see the image data it is. 

Standard Deviation 

The Standard Deviation stretch type applies a linear stretch between the values defined by 

the standard deviation (n) value. 

Percentage Clip 

Percentage Clip stretch is the default setting for raster files and it is used to brighten raster 

data that normally appear dark. The Percent Clip stretch type applies a linear stretch 

between the percent clip minimum and percent clip maximum pixel values defined  

To set Stretch parameters go to the Show Histogram and Adjust and change type of Stretch 

or value of it.  

 

Figure 20. Parameters for stretching. 



Example 

Compare the following displays of the same layers: 

 

Figure 21. Left: Three layer mix (red, green, blue) without stretching. Right: Three 
layer with Standard Deviation (2.0). 

3.2.1.8. Look-up Table 

You can see Look-up Table which is great tool to make up the difference between source file 

and result of computation. To open Look-up Table go to the Table of Contents and select raster 

file and click right mouse button. In the displayed context menu click on Show Histogram and 

Adjust and change bookmark to Look-up Table. 

3.2.2. Change Display of Vector Layers 

You can define the colour and style for the display of vector layers. Go to the Table of Contents 

and select vector file and click right mouse button. In the displayed context menu click on Edit 

Style. User can change three basic choices for all vector. 



 

Figure 22. Edit style window for vector. 

3.2.2.1. Edit Point 

For points it is size of point, fill colour and symbol of point. The various symbols are 

available on the dropdown list. The default symbol is circle.  

 

Figure 23. Left: Edit style window for point; Right: Dropdown list with available 
symbols for point. 

3.2.2.2. Edit Line 

For lines it is fill colour, line thickness, style of line, line join and line cap. The default style 

is solid line but user can choose other which are on the dropdown menu. 

 



 
Figure 24. Edit style window for line. 

 

 
Figure 25. Dropdown lists with available style for line, line join and line cap. 

 

3.2.2.3. Edit Polygon 

For polygons it is fill colour, outline colour, outline thickness and pattern fill. The default 

pattern is solid but user can choose other which are on the dropdown menu. 

 
Figure 26. Left: Edit style window for polygon; Right: Dropdown list with available fill 

pattern for polygon. 

 

3.1.3. Zoom within project 



To navigate within display of a project, you can use the various zoom and pan functionalities.  

To navigate the project display in the View Area, do one of the following: 

 Select button from the Zoom toolbar 

 Click in the View Area and use the mouse wheel 

 On the main menu bar, choose View->Zoom  

 

Figure 27. Zoom toolbar. 

3.1.3.1. Zoom 100% 

Click the Zoom 100% button to display the file at its original scale.  

3.1.3.2. Zoom using the Mouse Wheel 

If your mouse has a scroll wheel, use it for zooming. Click in View Area. Scroll the mouse 

wheel to the front to zoom in. Scroll the mouse wheel to the back to zoom out. 

3.1.3.3. Zoom In 

Select the Zoom In and click in the View Area to enlarge your file from a point. This means 

you can enlarge the specific area of interest. 

3.1.3.4. Zoom out 

Select Zoom Out and click into View Area to zoom out from a point. This means you can 

specifically zoom out from the region of interest. 

3.1.3.5. Select Zoom Value 

Select or enter a zoom value to change the display in the project view. 

 

Figure 28. Zoom toolbar. 

3.2.3.6. Panning 

To move within View Area, use the Panning cursor. To activate the panning mode click Pan 

button from the View Toolbar. 

3.2.4. Coordinates in Layer 

While holding the mouse pointer over the layer, its coordinates are displayed in the box in 

the bottom menu in AgroEye.  



 

Figure 29. Coordinates box  in AgroEye. 

 

3.3. GAEC rules 

This chapter introduces the technology and development workflow for GAEC rules and 

explains the basic tools. You can use basic GAEC rules.  

3.3.1. Start with GAEC rules 

To start work with GAEC rules choose GAEC→Choose rules on the main menu bar. You can 

also use the Ctrl+K to open GAEC rules window. In the top you can choose the number of rules 

which you can analyse. Next you can click on the green block to set parameters and run 

calculations.  

 

Figure 30. GAEC window. 

3.3.1.1. Raster Input 

You can set the file to GAEC rules and choose directory to save new layers. 



 

Figure 31. Input files window. 

3.3.1.2. Segmentation 

The fundamental step of GAEC rules is a segmentation of raster file. Thus, initial segmentation 

is the subdivision image into segment represented by image objects. Different segmentation 

algorithms provide several methods of creating of image objects. In AgroEye you can set 

Quadtree, Chessboard or Shephard Segmentation.  

 

Figure 32. Segmentation window. 

3.3.1.3. Table View 

After segmentation you can see the results of computation. The table shows the NDVI. You 

can set minimum and maximum value of the NDVI. 



 

Figure 33. Table View. 

3.4. Additional Features 

3.4.1. Measure distance and area  

To start work with measure tools choose Tools → Measure or Tools → Measure Area.  

You can measure the area of a polygon or the length of a line. This functionality calculates 

shortest distance or area using the planar measurement type which is 2D Cartesian 

mathematics. You  draw line or polygon on the layer to get its length or area. You can change 

the default units of measurement.  If you change units after making measurement, the current 

result will be converted to the newly selected unit. Tools are available only if view area has 

defined coordinate system.  

 



  

Figure 34. GUI for measure distance and area. 

 

Figure 35. Example of measuring.  

3.4.2. Raster Calculator 

To start work with raster calculator choose Raster calculator. 

It allows to create Map Algebra expression that will output a raster. Raster calculator window 

contains four areas. The first is list of bands of all loaded raster files. Second area contains 

calculator buttons with operators. By clicking any of these buttons, operator enters into the 

expression where the pointer is currently positioned. The next area is section with expression 

to be executed. The expression have to be entered with valid syntax. Last area is tool for set 

range of display value. After click button Ok you set name and path of new raster file. 



 

Figure 36. Raster calculator. 

 

3.4.3. Create new vector layer 

You can add own vector layer, for example to mark boundary line. Before you can add new 

vector object, it is necessary to create vector dataset to add it to. Option Create New Layer is 

in the Tools menu.  Following dialog will be presented:  

 
Figure 37. Dialog for add new vector layer. 

It is important to decide which kind of geometry type it will be created. Each different type 

has other properties, so change its type after create dataset will not be possible. You can 



choose Point, Line and Polygon type. The next step allows to specify the coordinates 

system. The default coordinate system is WGS84. You can change SRS by clicking on the 

Add Button and set new SRS from the list.  

 
Figure 38. Dialog for set coordinates system. 

 

Next properties to set is a collection of fields. By default, a new layer has only one attribute, 

the ID field. However you can add new field, delete and rename existing.  

When new dataset will be created, the next step is add object It is as follows: 

 
Figure 39. Dialog for add to layer new object with coordinates table. 

User can see coordinates and attributes of added object. User mark the object on the 

ViewArea.  



 

Figure 40. Drawing new object 

 

When the drawing command finishes, the user can set attribute for new object.  

 
Figure 41. Set attribute for a new object 

Coordinates and attributes of new object are automatically added to the table. User can edit 

this table but only after complete drawing.  

 
Figure 42. Edit attribute of new object.  


